SAP Knowledge Base Article - Public

3021548 - Error Appointment From An Activity Plan Cannot Be Added In Routing Rule For Ticket

Symptom

An appointment could not be added from an existing activity plan in routing rule for ticket due to error "Activity Plan cannot be added to this routing rule, as appointment/phone calls are not allowed for selected object type in this rule".

Environment

SAP Cloud for Customer

Reproducing the Issue

Prerequisite: You have already created an Activity Plan and added appointment to it.

  1. Go to the Activity Planner work center.
  2. Select the Routing Rules view.
  3. Click the New button in order to create a new routing rule.
  4. Fill in the required fields.
  5. Choose the Ticket value for the Business Application field.
  6. Click the Save and Open button.
  7. Define the conditions, under the Conditions facet.
  8. Go to Activity Plans facet.
  9. Click on Add button.
  10. Activity Plan screen window pops up.
  11. Use value search on Name field to select the Activity plan as mentioned in prerequisite.
  12. Error "Activity Plan can not be added to this routing rule, as appointment/phone calls are not allowed for selected object type in this rule".

Cause

In existing design there is a validation, due to which Activity Plan with appointment and phone call can be only added for Opportunity and Customer quote. This is not available for tickets.

Resolution

Currently, Activity Plan with appointment cannot be added in Routing Rule for Ticket. This is an expected behavior.

Keywords

Error Activity Plan, Can Not Be Added, Routing Rule, Appointment/ Phone Calls, Not Allowed, Selected Object Type, In This Rule, Ticket , KBA , error activity plan,not be added, ticket , appointment, phone call, not allowed , LOD-CRM-ACT-ROT , Activity Routing , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions