Symptom
Error message M8140 "Acct assgt XX for order item XXXXXXXXXX XXXXX does not exist" appears when reversing Credit Memo Invoices.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open Fiori App Supplier Invoices List.
- Click "Reverse" button and maintain information related to reversal.
- Click "OK" button, the error message "Acct assgt XX for order item XXXXXXXXXX XXXXX does not exist" appears.
Cause
This is a GR/IR based invoice and credit memo. By deleting the Service Entry Sheet(SES) the goods receipt was cancelled however the invoice or credit memo is not affected by that. Now if try to reverse the invoice or credit memo, the application tries to reference the no longer existing goods receipt. That is the reason why this error message occurs.
Resolution
Please create a new supplier invoice referencing the valid goods receipts.
Keywords
Service Entry Sheet, SES, Supplier Invoices List, F1060A, GR/IR based, Acct assgt, Credit Memo, Reverse, Goods receipts, MIRO, M8140 , KBA , MM-FIO-IV , Fiori UI for Invoice Verification , Problem