Symptom
A field being mapped from Recruiting to Employee Central is not being populated in Manage Pending Hires page.
Environment
SAP SuccessFactors Recruiting
Reproducing the Issue
- Check the value in Recruiting, confirm that there are values on the field;
- Access Manage Pending Hires, check the same field;
- Notice that the field where the information as mapped to, is blank.
Cause
This is caused by an incorrect configuration on a field on Recruiting side.
Resolution
When a field is incorrectly configured in Recruiting side, some unpredictable behaviors can be seen, but the most common is that the system is not able to read, or find the information inside it, and on this case, the system is not able to read the information via API to populate in Manage Pending Hires.
To confirm that the problem is still on the Recruiting Management side, access provisioning, and execute a Suite Test Integration. This will give you which specific data is being transferred from Recruiting to EC. If the result for that specific field is like "[...] {EntityRecordFieldValue: {rawValue: null, localizedValue: null, rawObject: null, [...]", then a couple of things look for when reviewing the configuration:
- Check for custom field being defined as a Standard or vice versa. The field that is custom should always be set as custom="true" and the standard ones should be custom="false";
- Verify if the same field with different type on another template. For example in application templates, the same field-id could happen to be used for a different thing in a different template, with a different type, and then the system wouldn't be able to read the data inside it;
- Confirm that the field in use on the Transformation template is the exact same as the one existing on the template.
Keywords
manage, pending, hires, missing, value, information, data, empty, blank, custom, field, id , KBA , LOD-SF-RCM-MPH , Manage Pending Hire , Problem