SAP Knowledge Base Article - Public

3023154 - Not Able to Logon Using SSO on C4C Extended Mobile App

Symptom

You are using Cloud 4 Customer Extended App in your Apple mobile device and face an error when trying to logon using single sign-on (SSO) authentication.

Errors:

  • No RelayState mapping found for RelayState value.
  • SAML2 service not accessible.

Environment

  • SAP Cloud for Customer
  • SAP Cloud for Customer Extended App (Mobile application for IPad and IPhone)

Cause

The iOS SSO uses ASWebAuthenticationSession control, which in turn is an embedded browser view. This browser loads and displays the page, from which the user can authenticate.

ASWebAuthenticationSession works closely with Safari and it uses session stored in Safari.

When you try connecting the C4C tenant using SSO, the webview redirects to the IDP which initiates a session and the user entered credentials are saved in a session as Web site data or cookies.

So if you're authenticating to an OAuth service/app and that service maintains a user's session in Safari then you might see it auto-authenticate you without having to re-enter a username/password.

Resolution

Users should perform this action:

  1. Settings ->Safari -> Clear History and Web site Data.
  2. Settings ->Safari-> Advanced-> Web site Data-> Remove All Web site Data.

After performing this action the problem will be solved.

Keywords

Apple, SSO, single sign-on, Mobile, RelayState  , KBA , AP-RC-MOB-IPD , SAP Hybris Cloud for Customer Extended App on iOS , SRD-CC-SEC , Security , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2011