SAP Knowledge Base Article - Public

3023597 - Report execution fails with the error "cannot allocate enough memory" in the logs

Symptom

  • Error while executing the report online and the Support team finds the error "cannot allocate enough memory" in the logs
  • Error while previewing the report and the Support team finds the error "cannot allocate enough memory" in the logs
  • Report executed offline has the status "Failed". The error message below appears in the Job Details: Error encountered in executing the query: cannot allocate enough memory

Environment

SAP SuccessFactors HXM Suite

Reproducing the Issue

  1. Go to Report Center
  2. Execute the report
  3. You'll face an error while executing it

Cause

The report's execution depends on many factors, it is related to the RBP permission + target population complexity, report's size + logic/complexity and data flow at the moment the user runs the report.

Resolution

Reduce the report's volume of data by applying filters, selecting fewer datasets or trying to execute the report offline during non-business hours.

Keywords

Report Failed Error encountered executing the query, cannot allocate enough memory, adhoc, table, detailed reporting, advanced reporting, canvas, ord , KBA , LOD-SF-ANA , Analytics & Reporting (Ad Hoc, YouCalc, ORD) , Problem

Product

SAP SuccessFactors HCM Suite all versions