Symptom
- Buttons 'Edit' and 'Submit' disappear when using the app “My Maintenance Requests”
- When accessing a notifcation in the app 'My Maintenance Requests' , the buttons for Edit / Submit appear briefly then disappear.
Environment
- Asset Maintenance (PM)
- SAP S/4HANA, cloud edition
Reproducing the Issue
- Open app “My Maintenance Requests”
- Select a notification
- The Buttons 'Edit' and 'Submit' appear in the Top Right Corner.
- After a few seconds , the buttons disappear
Cause
1. When a user creates a maintenance request from the application "create maintenance request" the request is already submitted to the screener and further edit on the maintenance request is not allowed
by the inititiator in my Maintenance Requests app . howerver the screener can go to the app Screen maintenance Requests and edit the maintenance request with additional data.
2. The other option is that the screener might use the button "Action required" to send the request back to the initiator.
This request with status "action required" can then be edited in my maintenance requests app from the Tab " Action Required" and can be submitted again using the Submit button.
Please note , The buttons edit and submit will be visible only in the tab " Action Required" .
The process is determined based on the role .
In the Technican / Employee role only my maintenance requests and create maintenance requests can be accessed
whereas in supervisor role the user has access to screen maintenance requests along with the other two apps.
Resolution
System works as Designed
Keywords
MAINTENANCE_PLANNER , BR_MAINT_SUPERVISOR , KBA , PM-FIO , Fiori User Interface (UI) for PM , PM-FIO-2CL , Fiori User Interface (UI) for PM (Public Cloud) , Problem