SAP Knowledge Base Article - Public

3024422 - Sales Orders Created On and Creation Date Fields Filtering not Displaying Correct Results

Symptom

You are filtering information from Sales Orders using Created On and Creation Date as criteria; however, results are not what you expect.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Open the Sales Orders Work Center;
  2. Select the "All" query;
  3. Open the Advanced Filter icon
  4. Set a filter using Created On and/or Creation Date''.

You see discrepant/incorrect results.

Cause

The "Created On" is a technical attribute that is set when the sales order is saved in C4C on creation. The "Creation Date" is the business date the sales order is created at. If the order was created in C4C, then by default, it is set to the current date. However, this date can be set by the user manually to any value. If the order is replicated from ERP, then the Creation Date might be set to the date when order was created in ERP.

Resolution

This is the system current standard behavior.

Keywords

Sales Order ; Created On ; Creation Date ; Filter ; Search ; Advanced Filter ; , KBA , LOD-LE-CQP-CO , Lean Sales Orders , AP-RC-UIF , C4C UI Framework , How To

Product

SAP Cloud for Customer core applications 2011 ; SAP Cloud for Customer core applications 2102