Symptom
- It is not possible to change (delete & then add) Sold-to Party in a ticket because fields (Name, etc.) are grayed out.
- It is impossible to edit actual quantity in Item Level.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Service work center.
- Go to the Tickets view.
- Open ticket ABC (ABC represents the ticket ID).
- Go to the Involved Parties facet.
- Delete Sold-to Party.
- Click Add button.
- Select Sold-to Party from the dropdown.
- Name and other fields are grayed out and you cannot add different Sold-to Party.
Or
- Go to the Service work center.
- Go to the Tickets view.
- Open ticket ABC. (ABC represents the ticket ID).
- Go to Item tab.
- Click on Edit.
- The actual quantity field ( many field for Product) is read-only.
Cause
Work Progress status on some of the items is already set to Finished ,In such a case, the aggregated status on the ticket is also Finished, and Sold-To Party (Buyer Party) becomes read only. And the Work Progress in header is Finished.
Resolution
- Go to Service Work Center.
- Go to Tickets View.
- Open Ticket XYZ ; XYZ is Ticket for which Item's Work Progress needs to be reverted.
- Select the Line Item and click on More.
- "Undo Work Progress".
Keywords
service request, ticket, status, finished, sold-to, buyer, party, involved party, add, grayed out, greyed out, read only, edit, delete, actual quantity, Item, Work Progress , KBA , LOD-CRM-SRP , Service Request Processing , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions
SAP Knowledge Base Article - Public