SAP Knowledge Base Article - Public

3024892 - Some fileds are read-only or It is not possible to change (delete & then add) in ticket

Symptom

  • It is not possible to change (delete & then add) Sold-to Party in a ticket because fields (Name, etc.) are grayed out.
  • It is impossible to edit actual quantity in Item Level.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Service work center.
  2. Go to the Tickets view.
  3. Open ticket ABC (ABC represents the ticket ID).
  4. Go to the Involved Parties facet.
  5. Delete Sold-to Party.
  6. Click Add button.
  7. Select Sold-to Party from the dropdown.
  8. Name and other fields are grayed out and you cannot add different Sold-to Party.

Or

  1. Go to the Service work center.
  2. Go to the Tickets view.
  3. Open ticket ABC. (ABC represents the ticket ID).
  4. Go to Item tab.
  5. Click on Edit.
  6. The actual quantity field ( many field for Product) is read-only.

Cause

Work Progress status on some of the items is already set to Finished ,In such a case, the aggregated status on the ticket is also Finished, and Sold-To Party (Buyer Party) becomes read only. And the Work Progress in header is Finished. 

Resolution

  1. Go to Service Work Center.
  2. Go to Tickets View.
  3. Open Ticket XYZ ; XYZ is Ticket for which Item's Work Progress needs to be reverted.
  4. Select the Line Item and click on More.
  5. "Undo Work Progress".

Keywords

service request, ticket, status, finished, sold-to, buyer, party, involved party, add, grayed out, greyed out, read only, edit, delete, actual quantity, Item, Work Progress , KBA , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions