Symptom
Although the status of the sales document is "in approval", the approver does not receive the approval request either in the "My Inbox" app or in the "Notifications" section on the top right corner. Meanwhile, there is an error "No users found for task" in the approval details of this sales document. The approver shows only as a recipient but not as a processor.
Environment
SAP S/4HANA CLOUD
Reproducing the Issue
Here take the credit memo request as an example. It will be the same for other types of sales documents relevant to the workflow process.
- Sales document workflow has been set up and the recipient is assigned by user (the recipient can also be assigned by role, which will not be discussed here).
- Create and save a credit memo request and find the status of this credit memo request is "in approval".
- However, the approver does not receive this credit memo request either in the "My Inbox" app or in the "Notifications" section on the top right corner.
- Meanwhile, open the "Manage Credit Memo Requests" app and click "Go".
- Click on the number of this credit memo request and then click on this number again.
- Under the "Approval Details" tab, find the error "No users found for task". The approver shows only as a recipient but not as a processor.
Cause
The user responsible for approving workflows (the recipient) is not assigned with the business role "Sales Manager (BR_SALES_MANAGER)".
Resolution
Open the "Maintain Business Users" app and assign the user responsible for approving workflows with the business role "Sales Manager (BR_SALES_MANAGER)".
Keywords
Sales Document, Workflow, Approval Request, Status, In Approval, My Inbox, Notifications, No Users Found For Task, Approval Details, Maintain Business Users, Approver, Recipient, Sales Manager, BR_SALES_MANAGER, Credit Memo Request, Sales Quotations, Sales Contracts, Sales Orders, Customer Returns, Preliminary Billing Documents , KBA , SD-SLS-SO , Sales Orders , SD-SLS-SO-2CL , Sales Orders (Public Cloud) , Problem