SAP Knowledge Base Article - Public

3026250 - Extension Scenario from Contact to Contract is Not Working

Symptom

Extension scenario from Contact to Contract is not working for extension field XYZ (XYZ represents the extension field name)

Extension scenario: Account - General Information to Contract - General Information

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Contacts work center, open one Contact. In the Header place (take Header as example), there's a KUT extension field XYZ which has value filled. 
  2. Switch to Adpat mode, to edit the extension field XYZ. 
  3. Edit this field and navigate to "Extension Scenarios". Then you can see this field is extended to contract BO. Extension scenario: "Account - General Information to Contract - General Information" is selected. 
  4. Now leave adapt mode. Open the associated Account of this contact. 
  5. Go to Contracts tab, create a new contract to make the contract associated with this account and contact. 
  6. Now, if you check the same field XYZ in the created contract, you see the value is not copied here. 

Cause

Currently Extension Scenario from Contacts to Contracts is not supported, only Accounts to Contracts is supported.

Resolution

The extension field need to be created in the Account instead of the Contact.

Note: in case you have enabled the extension scenario "Account - General Information to Sales Document - General Information", it will only let the data flow from an Account used in a business document (so not Ship-To or Contact) into a Sales Document. 

There is no extension scenario from the Contact to the General Information Section of a Contact. This has to be coded by PDI if needed.

Keywords

Extension Scenario, Contact, Contract, Account , KBA , LOD-LE-COP-SLS , Sales Contract , How To

Product

SAP Cloud for Customer core applications all versions