SAP Knowledge Base Article - Public

3026274 - Candidate Profile Still Inactive After Start Date (Main KBA) - Onboarding

Symptom

  • The candidate is still inactive even after start date is passed.
  • The hired candidate is still showing inactive in employee profile.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Login to BizX
  2. Navigate to employee Profile
  3. Search for candidate
  4. View candidate status is inactive even after Start Date

Cause

  • Cause 1: The Process status in Manage Data > Process object is not set to OPEN. It's possible that the status is set to completed by the process closure Job. 
  • Cause 2: The ConvertExternalUseronStartDate Job is not configured in provisioning / HRIS Sync and ConvertExternalUserOnStartDate running at the same time.
  • Cause 3: Hire Status is not set to "Hired" and Event Type is not set to "Hire" in Manage Data > Process.
  • Cause 4: Candidate's Hire Date is after the Target Date.
  • Cause 5: Issue caused by a stale index on the SOLR search database.
  • Cause 6: Onboarding process is not fully completed. 
  • Cause 7: Timezone is not maintained.
  • Cause 8: username updated during Manage pending hire (MPH), but the new username is already used by someone else

Resolution

Solution 1: Workaround for affected user:

  1. Navigate to Manage Data > Process
  2. Search for candidate by user id or ONB process id
  3. Take action > Make Correction
  4. Change Process Status to "Open" & Tasks Status to "Open" > Save
  5. Run the ConvertExternalUserOnStartDateJob in Provisioning 
  6. After 15 mins, run the HRIS Sync job 

If the closure Job is picking the candidate and setting the process status to Completed, then you can modify the Archive onboarding and offboarding process business rule so that the future candidates are not affected. Follow below steps to modify the rule: 

  1. Navigate to Configure Business Rules
  2. Search for rule SAP_ONB2_ProcessClosurePeriodConfig
  3. Take Action > Make Correction
  4. Set the Closure Period days to a minimum of 30 days to give the convert job a chance to pick up the candidates.

Solution 2: Go to Provisioning -> Manage scheduled Job. Check and validate if the ConvertExternalUserOnStartDateJob is configured. If not, kindly configure the Job and validate under Monitor Job section if this Job is running successfully. KBA: 2895988 - Setup Day 1 Conversion Job Concept - Onboarding - SAP for Me 

IMPORTANT TO NOTE: HRIS sync Job and ConvertExternalUserOnStartDateJob both SHOULD NOT be running parallelly. Kindly keep intervals between the Jobs. 

It is recommended to keep time gap when HRIS SYNC_Recurring job/ConvertExternalUserOnStartDateJob is running (maybe run at hour+30min - can keep in 1h intervals).

For affected candidates, kindly open a ticket with Onboarding Support team once a script will be required:

  • Raise a ticket to component: LOD-SF-OBX-JCN
  • Information needed: Company ID, Support Access and User ID/Users Sys ID of affected candidates
  • Your approval to run script for candidates not converted

Solution 3: Following are the criteria which needs to be met to pick candidate for conversion job:

  1. Active Event from the Event Reason from job history, it must be Hire
  2. Process Status it must be OPEN
  3. Hire Status it must be HIRED

If one of the conditions not meet as above the conversion job will not convert the user.

Solution 4: In Manage Data check with the Process ID of affected candidate, note that the Hire Date is after the Target Date.

In order to solve this problem for affected candidates, kindly follow steps:

  1. Open candidate's page in EC.
  2. In Employment Information section go to "Job Information".
  3. Click on the Clock icon.
  4. After page is opened click on "Edit" bottom.
  5. Edit any information in this page (like Location), and save it.
  6. After that, reopen this section and change it back.
  7. Job will run and convert it.

Note: The Process Status (in Manage Data > Process > Process ID of affected candidate) must be "Opened". If it's already Completed/Closed, it's necessary to manually update it (referring to steps in "Solution 1").

To avoid this issue to happen again, Hire Date must always be before or the same date as Target Date.

Solution 5: It's necessary to rebuild the SOLR Index. Kindly reach out to Platform Team and raise ticket with component (LOD-SF-PLT). Refer to internal KBA to PLT team.

NOTE: For Support Engineers, kindly check the internal Memo for additional troubleshooting steps.

Solution 6: Check if all Onboarding processes have been completed: 

  1. Review New Hire Data
  2. Personal Data Collection
  3. Additional Data Collection
  4. Document Flow
  5. Manage Pending Hires


Solution 7:
Add timezone information. KBA: 3423980 - Rehire with old employment employee not converted after start date - Onboarding - SAP for Me

  1. Go to "Manage Business Configuration"
  2. Job information
  3. Enable the field "timezone" and click save
  4. Create a business rule and add it as onChange under JobInfo.location field.The rule will be based on Job Information base object, with condition: if always true, then set jobInfo.timezone equal to jobInfo.location.timzone
  5. Add this rule using Manage Business Configuration tool under > jobInfo > location field details 
  6. Click save
  7. Test with a new candidate

Solution 8: Use updateUserNamePostHiring API to update the username to a unique one.

To identify the username updated dring MPH, Support needs to raise a script. Please review internal memo to find more details.

    See Also

    Keywords

    Onboarding, OBX, candidate, profile, inactive, active, Conversion, Job, ConvertExternalUserOnStartDate, still, after, start date, not, converting, employees, username in users_sysinfo table exist , KBA , LOD-SF-OBX-EC , Integration EC - MPH, Hire , Problem

    Product

    SAP SuccessFactors Onboarding all versions