Symptom
You have released some customer invoices which are valid for rebate.
You scheduled a rebate agreement run but the run did not create any credit memo invoice requests.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Rebate Management work center.
- Go to the Rebate Agreement and Settlement Runs view.
- Select run ABC and open the last execution log from the Execution Details table.
- There is no credit memo invoice requestion created.
Cause
There are many reasons causing the credit memo invoice request not creating from rebate agreement run.
Here in this case, the reason is due to Extension Fields value mismatch. There is one extension field ABC enabled on Rebate Agreement Run and Invoice Request. The value set in the Rebate Agreement is X, however in the invoice request the default value is maintained as B. (ABC represents the extension field ID and X, Y represents the value of the extension field).
When running the Rebate Agreement run, system checks the all parameters in the rebate including the extension fields. Since the values are different, the credit memo is not created.
Note, you will have to check if there is any extension field is enabled but hidden in UI.
Resolution
Ensure the extension fields have same value in Rebate Agreement and Invoice Request.
See Also
2831487 - Rebate Credit Memo not Created; Accrued Amount is Zero
Keywords
Rebate Agreement; Credit Memo; Extension Field;Rebate Credit Memo not Created; , KBA , AP-CI-CI , Customer Invoice , Problem