Symptom
Service Orders and Services Confirmations are not shown, when you search on the data source CRMSRSCIB.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Business Analytics work center.
- Navigate to the Data Sources view.
- Open the Data Source Service Order Item & Service Confirmation Item (CRMSRSCIB).
- Click on the Preview button.
- Click on the Apply button.
- You can see the data source does not display the data.
You expect that Service Confirmation XYZ (XYZ represents the ID of the service confirmation) is displayed here.
Cause
This report only shows data for those sales order which have service confirmations linked to them. In your system, there are no such sales orders.
Resolution
The Service Order / Service Confirmation should be referenced on Item Level:
- Go to the Field Service and Repair work center.
- Open the Service Confirmations view
- Search for the Service Confirmation XYZ (XYZ represents the ID of the service confirmation).
- Click on Edit button
- Click on the View All Button
- Navigate to Services and Spare Parts tab.
- Select the line item.
- You can see that in the field Reference Service Order/Item no value is maintained. You need to maintain the Sales Order and Line Item of the respecive referenced Sales Order.
Keywords
Service Order; CRMSRSCIB; Data Source , KBA , AP-SVO-SO , Service Order , AP-SCO-SC , Service Confirmation , How To
Product
SAP Business ByDesign all versions