SAP Knowledge Base Article - Public

3027701 - Recommended Visit Frequency from Account is Not Considered when Working in Offline

Symptom

An Account has a Recommended Visit Frequency set but you do not see this being considered when creating a new Visit for the account.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Click in the Profile menu.
  2. Select the Sync now option and wait for it to complete.
  3. Click in the Profile menu.
  4. Select the Go Offline option.
  5. Open the Account ABC (where ABC is the Account ID).
  6. Go to the Visits view, observing the Recommended Visit Frequency DEF (where DEF is the Recommended Visit Frequency set).
  7. Click in the New button.
  8. Fill in the mandatory fields required.
  9. Select Save and Open.
  10. Click in the Check-in button.
  11. Click in the Check-out button.
  12. In the popup that appears "Create a New Visit?", select the OK button.

The Start Date field will be the current day instead of (current day + DEF).

Cause

This is a current limitation of offline mode.

Resolution

This is the current system standard behavior.

You can request this as an improvement in the current system standards via SAP Customer Influence Session.

If you need this functionality urgently you may contact the SAP Customer Experience Services as follows:

a) If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder.

b) If you are a customer: please use the little blue box “Contact Us” shown on the very right-hand side of https://www.sap.com/uk/services/advisory-development/application-development.html#contact-us and choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page.

Note: The services of the SAP Customer Experience Services will be charged as packaged services based on fixed prices.

Keywords

Account ; Visit ; Recommended Visit Frequency ; Offline ; , KBA , LOD-CRM-ACT-VST , Visit Planning , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer core applications 2102