SAP Knowledge Base Article - Public

3028742 - How to delete the time sheet entries?

Symptom

The User has made time sheet entries which are not yet approved in the system, the User would like to mass delete these entries.

Environment

SAP S/4HANA Cloud Public Edition

Cause

The deletion of these entries from SAP directly through the backend is a complex topic. It is necessary to check carefully the entries that will be deleted and follow a strict process in order to ensure consistency. Hence, if possible, the best option is the customer making the deletion through an API, or manually on the front end.

Resolution

There are two main scenarios with different recommendations:

  1. Scenario 1 - Employees of the entries are still active: The recommendation in this case is to delete these entries through the API (API_MANAGE_WORKFORCE_TIMESHEET) or manually on the front end (through app Manage my Timesheet app) to ensure consistency.
  2. Scenario 2 - Employee is inactive: The recommendation is to use app ‘Notify Missing Times’ to update the inactive employee’s timesheet within 60 days of employment termination. If the employee is inactive for more than 60 days then the time entries can be deleted via API_MANAGE_WORKFORCE_TIMESHEET. Please refer to https://community.sap.com/t5/enterprise-resource-planning-q-a/how-to-update-delete-in-api-manage-workforce-timesheet/qaq-p/12379347 for an example payload for deleting time entries.
    Note : Only Internal Employee’s are supported as of now & contingent worker’s data can not be updated via this app.

See Also

SAP Help - Manage Workforce Timesheet API
SAP Help - Notify Missing Times
SAP Community - How to update / delete in API_MANAGE_WORKFORCE_TIMESHEET

Keywords

deletion, employee, timesheet, posting, notify missing times, API_MANAGE_WORKFORCE_TIMESHEET, 60 days , KBA , CA-TS-S4 , Cross Application Timesheet in S/4HANA , Problem

Product

SAP S/4HANA Cloud Public Edition all versions