SAP Knowledge Base Article - Public

3028880 - Employee cannot create external candidate profile due to account already exists - Recruiting Management

Symptom

The original external candidate profile has been converted/merged into Internal candidate profile via External to Internal Candidate Profile conversion.

The employee cannot re-use the primary email address to create a new external candidate profile, although there is no duplicate.

  • Error on career site: "Account Already Exists"
  • Error when Recruiting admin adds new candidate: "The information you entered matches candidate records already in the system"

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. A candidate was hired as an employee previously;
  2. The original External Candidate Profile has been merged/converted into Internal Candidate Profile;
  3. Due to termination, the employee has become inactive;
  4. The candidate (ex-employee) tries to re-use the primary email address to create a new external candidate profile;
  5. It shows "Account Already Exists".

Cause

This is an expected behavior as the system will not allow to create an account using the same email address that exists in the RCM_CAND_PROFILE_CONVERSION table.

The POSTCONV_EXT_EMAIL_ADDRESS field in RCM_CAND_PROFILE_CONVERSION table will store the primary email address of the candidate prior to conversion even if we do not configure that field ("postConvExtContactEmail") in Candidate Profile Template.

Resolution

Solution 1 - Purge the internal candidate profile

There are two ways to purge the internal candidate profile:

1) (DPCS 2.0 purge routine) Delete/Anonymize the internal candidate profile and then purge the data via RCM Entity Anonymization job

Step 1: Delete/Anonymize the candidate profile

  • Employee: Careers > My Candidate Profile > Delete Profile
  • Admin user: Admin Center > Anonymize Candidate Profiles > Anonymize Candidate Profiles and Applications

Step 2: Run RCM Entity Anonymization job from provisioning

2) (DRM/DTRM purge routine) Data Retention Management > Purge Inactive User

Please uncheck “There is data for this user in Employee Central (EC)”

Download Preview Report – confirm that it shows “TO BE PURGED” in [RCMCandidateObjectType.csv]

Solution 2 - Employee to Candidate Deconversion

Employee to Candidate Deconversion will clean up the existing data and de-converts the internal candidate profile to external candidate profile.

For more information, please refer to KB articles in the See Also section below.

See Also

Conversion and Deconversion

  • KB article 2249476 - External to Internal Candidate Profile conversion - Recruiting Management
  • KB article 2081617 - Employee to Candidate Deconversion - Recruiting Management

Delete Candidate and RCM Entity Anonymization

  • KB article 2670133 - Anonymize Candidate Profiles Feature - Recruiting Management
  • KB article 2166333 - How To Set Up Anonymization - Recruiting Management
  • KB article 2103393 - Which data may be Anonymized, when using DPCS 2.0 - Recruiting Management

Purge Inactive User

  • KB article 2545988 - How to Purge/Delete users in SuccessFactors Cloud
  • KB article 2585473 - ##### Belongs to EC Data Thus Can't Be Purged / There is data for this user in Employee Central (EC)

Keywords

account, already, exists, external, candidate, ex-employee, hired, rehire, internship, conversion, deconversion, postConvExtContactEmail, unable, profile, deleted
, KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , LOD-SF-RCM-ADM , Admin Center, RBP, Permissions and Settings , Problem

Product

SAP SuccessFactors Recruiting all versions

Attachments

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