Symptom
You are trying to open an ESS mashup application in EC for a different user. However, application is opened for your own user or the user used to proxy to.
This can happen to any ESS application, like EA form, IR8E, etc.
Environment
Employee Central
Reproducing the Issue
- Logon to EC system as user A
- Search any other employee B
- Open Employee Profile, navigate to Payroll Information and open the affected mashup application
- You check that application is opened for employee A, instead of getting the application as employee B
Cause
Reason for that is that this is an ESS service. So whenever that is called (no matter from the admin or the self service), system will logon to the backend system and based on the user that does the logon, the corresponding PERNR to be displayed will be determined. So it will always be the admin mashup application.
Resolution
The admin user A should proxy as the employee B and check mashup application in his profile. In that case the logon will be done with the employee user B, so the system will determine his PERNR and mashup application for this employee B will be displayed.
See Also
Keywords
KBA , LOD-EC-GCP-PY-MAS , Employee Data Maintenance via Mashups , Problem