SAP Knowledge Base Article - Public

3029426 - Unable to Use E-mail Channel Address as Condition in E-mail Workflow Rule

Symptom

You are unable to use the e-mail channel address as a condition when creating an e-mail workflow rule.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Navigate to Administrator work center.
  2. Navigate to Workflow Rules work center view.
  3. Click New.
  4. Set the Business Object as e-mail.
  5. Fill in all mandatory details.
  6. Click Next.
  7. Click Add to add a condition.
  8. See that the e-mail channel address field is not available in the conditions list.

Cause

E-mail Address related fields, such as e-mail Channel Address, are not supported in Workflow Rules.

Resolution

This is the expected behavior for the Workflow Scenario.

If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available.

See Also

A similar scenario exists for extension fields of type e-mail address, as explained in KBA 2826167 - Extension Field Of Data Type Web Address and E-mail Address  Are Not Available For Defining  Workflow Rule (https://launchpad.support.sap.com/#/notes/2826167)

Keywords

E-mail, Channel, Address, Condition, Workflow, Workflow Rule, Rule, C4C, Cloud for Customer, Service, E-mail Channel, Unavailable, , KBA , LOD-CRM-SRP-WKF , Ticket Workflow , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions