Symptom
You are replicating Sales Order/Sales Quote from ERP/S4H to C4C and the CustomerOrderReplicationIn Service Interface fails with "ID mapping for external value 1234 of missing" error.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Web Service Message Monitoring under Administrator Work center.
- Search for the CustomerOrderReplicationIn Service Interface.
- You will be able to see the error.
Cause
The error is due to IdentifierDefiningSchemeCode field missing for a Sales Party (SalesEmployeeParty, SalesUnitParty...) in the C4C incoming payload.
Resolution
To fix the issue you need to pass correspondent value on the respective HCI node (SalesEmployeeParty, SalesUnitParty...), as you can see on the below example:
HCI Node
/ns0:CustomerOrderRequestMassRequest/CustomerOrderRequest/CustomerOrderRequest/SalesEmployeeParty/IdentifierDefiningSchemeCode
C4C Payload for SalesEmployeeParty
<SalesEmployeeParty>
<InternalID>1234</InternalID>
<RoleCode>AB</RoleCode>
<IdentifierDefiningSchemeCode>3</IdentifierDefiningSchemeCode>
</SalesEmployeeParty>
Keywords
ID mapping, Sales Order, Sales Quote, IdentifierDefiningSchemeCode. , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem