Symptom
You are following Intercompany Sales Order Processing - International (1MX) process flow and when trying to create a Billing document based on the Delivery a technical error occurs.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
*Intercompany business scenario
1. Open the app 'Create Billing Document'
2. Insert the Delivery as SD Document source for your Billing Document.
3. Check error message: 'A technical error occured.'
Cause
One of the causes for the technical error might be the Sales Area Data missing on the delivery document. This error is normally issued when there are missing customizing for determining fields LIKP-VKOIV (Sales organization for intercompany billing), LIKP-VTWIV (Distribution channel for intercompany billing), LIKP-SPAIV (Division for intercompany billing) in the referenced delivery document. In case Sales Area Data is correctly configurated please open a ticket as per 2563519 - SAP S/4HANA Cloud Public Edition - How to create the perfect case KBA.
Resolution
Check Master Data setup at "Intercompany Sales Order Processing - International (1MX)" Setup guide at https://support.sap.com/content/dam/SAAP/Sol_Pack/Library/Setup/1MX_Set-Up_EN_XX.pdf. If already configurated please double check section 3.1.2 Customer Sales Area Data, specially the fulfillment of the fields LIKP-VKOIV (Sales organization for intercompany billing), LIKP-VTWIV (Distribution channel for intercompany billing), LIKP-SPAIV (Division for intercompany billing).
Keywords
Intercompany Billing Document, Technical Error, 1MX, , KBA , SD-BIL-IV-IB , Intercompany Billing , Problem