Symptom
When you create a Customer Contract, Materials are not visible in the value help of the line item, although the material is available in Products View of Product and Service Portfolio work center
Environment
SAP Business Bydesign
Reproducing the Issue
- Go to Sales Orders work center.
- Select New Contract from the common tasks.
- Add the relevant Account, Sales Unit and Distribution channel.
- Navigate to Items tab.
- Select value help of Product ID, you can see no materials are displayed.
Cause
The Products/Materials are not available when you try to add the items in the Customer Contract or Customer Contract Template because of your scoping decisions. In order to use the Materials in Customer Contract, you need to scope Materials in Customer Contracts.
Resolution
To scope Materials in Customer Contracts, please follow the below steps
- Go to the Business Configuration work center.
- Go to the Implementation Projects view.
- Click on Edit Project Scope and go to section 4. Questions .
- Select Sales>Selling Products and Services>Customer Contracts
- Under Questions for Customer Contracts , Select the Group: Materials in Customer Contracts
- Select the Question Do you want to work with materials in contracts ? and add it scope by clicking on the checkbox
- Click on Next and Finish you scoping
Keywords
Materials; Customer Contract; Products missing; Contract; Contract Template; , KBA , customer contract , products missing , contract , material , value help , AP-CCP , Customer Contract Processing , Problem