SAP Knowledge Base Article - Public

3030257 - SAP CPQ Integration with NetSuite Breaking Change

Symptom

Due to changes Oracle NetSuite is introducing in their system in March 2021, you’ll need to adjust the settings for your integration of SAP CPQ and NetSuite.

Environment

SAP CPQ

NetSuite

Reproducing the Issue

You have a working integration of SAP CPQ with Oracle NetSuite. This integration will stop working as of March 2021 because of changes in the NetSuite application.

Cause

The breaking change in the parameters in the Outbound SSO HTTP call has been announced by Oracle NetSuite: As of March 1, 2021, the dc and env parameters in the Outbound SSO HTTP call will be deprecated.

Resolution

You need to perform the following changes in SAP CPQ in order to maintain the integration working as expected:

  1. In CPQ, go to Setup;
  2. CRM Integration;
  3. General;
  4. In NetSuite SingleSignOn url, enter the new one as below:
  5. https://.suitetalk.api.netsuite.com/app/common/integration/ssoapplistener.nl and replace with the account ID of your specific NetSuite domain.

If you are using NetSuite web services URLs in your scripts, these should be changed as well to contain account ID.

  • In your scripts, add the account ID in the NetSuite web services URLs as in this example https://.suitetalk.api.netsuite.com/wsdl/v2015_2_0/netsuite.wsdl

Keywords

CPQ, NetSuite, Oracle NetSuite, CPQ Integration , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , How To

Product

SAP CPQ 2021