Symptom
You are replicating data from an external system to C4C. The C4C inbound message contains the KUT field and it is correctly filled, however the information is not being updated on the UI.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Web Service Message Monitoring under Administrator Work center.
- Search for the Inbound Service Interface.
- Open the Payload.
- Check if the KUT is correctly filled.
- Then go to the respective Business Object View.
- KUT field remains blank.
Cause
The issue is happening because the KUT field is extended to multiple Extension Scenarios.
You can check it by following the below steps:
- Go to the Respective Business Object View.
- Search for the KUT field.
- Select the User Menu on the right top corner of the screen.
- Choose the Start Adaptation mode.
- Find the field.
- Click on the Drill Down button.
- Click on Edit.
- Navigate to Extension Scenarios.
- You will be able to see all scenarios that are using the KUT field.
Resolution
To fix the issue, please select only one Extension Scenario per KUT field.
See Also
Keywords
KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To
Product
SAP Cloud for Customer add-ins all versions