Symptom
- Email is shown as sent in correct locale (e.g. de_DE) in Email Services but email text is not translated correctly. We can have rules set up for email locale.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Access BizX
- Navigate to Onboarding Dashboard
- Select Candidate
- See Tasks
- Select Nudge
- Review message and submit
Cause
- This is expected behaviour due to Email Services configuration and the use of a token named [[DynamicToken]]
- [[DynamicToken]] will be populated within the email template configuration for a Reminder/Nude email. This [[DynamicToken]] is the text that appears within the Onboarding Dashboard when you select ‘Nudge’.
- When click ‘Nudge’, the text that appears before submission will utilise the users current selected language, This means that is candidate is receiving the Nudge with de_DE locale and the user who initiated the ‘Nudge’ was sing en_US locale, the [[DynamicToken]] will pick up the en_US text and it is not translated.
Resolution
As this is expected behaviour the following is recommended;
- Please ensure that the person initiating the Nudge has the same locale active as the email template (i.e. If recipient of Nudge is expected to receive the email in German, please ensure that manager initiating the Nudge also has German locale active)
- Please create an enhancement request if you would like for text populated within [[DynamicToken]] to be automatically translated based on the locale used for the sent temple within Email Services
See Also
Enhancement Request: SAP Influence Portal
Keywords
Onboarding 2.0, Nudge, Email, E-Mail, Notification, Locale, [[DynamicToken]], Dashboard, Email Services, Template, Rules , KBA , LOD-SF-OBX-EML , Notifications , Problem
Product
SAP SuccessFactors Onboarding all versions