SAP Knowledge Base Article - Public

3032204 - New Meter Reading Button Not Available For All Premises in SAP Cloud For Customer

Symptom

New Meter Reading button is not available for all premises in SAP Cloud For Customer.

Environment

SAP Cloud for Customer Integration with SAP ISU

Reproducing the Issue

  1. Go to the Utilities work centre.
  2. Go to the Premise view.
  3. Search for and open premise ABC (ABC represents premise name/ID).
  4. Navigate to the Connection Details facet.
  5. Select the Device under Object Hierarchy.
  6. Under Meter Readings the New Meter Reading button is missing.

Cause

The action will be disabled if you are using advanced meter reading infrastructure (AMI).

Resolution

For AMI Meters, user is able to 'PING', Connect/Disconnect only. Also, we disable the "edit" button and "create" button from C4C system, as meter readings will be automatically updated by smart meters.

Please refer to the Help center documentation.
https://help.sap.com/docs/c4c-mobile-app/utilities-contact-center-administrator-guide/connection-details-944d7a01a0c2464488e8c0211790a15a?q=AMI%20data%20

Keywords

AMI Meter, New Meter Reading, Utilities, Meter, Premise, Connection Details, Device, Object, Connect, Disconnect, AMI, , KBA , LOD-CRM-IND-UTL , Utilities , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions