SAP Knowledge Base Article - Public

3032236 - The duplicate check message is sometimes not prompted

Symptom

When creating a new customer / supplier with the same value of some fields as existing customer / supplier, the duplicate check message is not always prompted in Manage Customer/ Supplier Master Data app.

Environment

SAP S/4HANA Cloud

Reproducing the Issue

  1. Open Manage Customer / Supplier Master Data.
  2. Copy information from an existing customer / supplier to create a new one.
  3. Click Check or Create button.
  4. The duplicate check message is sometimes not prompted.

Cause

SAP standard design.

Resolution

  • The conditions for the function of the duplicate check to be triggered are:

  1. All mandatory fields have to be filled.
  2. A duplicate is found only if the data has been entered for the relevant fields.
  • The message of duplicate check will be prompted only if the data in the address fields or Identification fields are matching. (But it is not a compulsion to fill in all the address fields and ID fields for the duplicate check to work.)

Keywords

S4_PC, S/4HANA Cloud, LO-MD-BP, AP-MD-BP, duplicate, check, create, customer, supplier, vendor , KBA , LO-MD-BP , Business Partners , AP-MD-BP , Business Partner , Problem

Product

SAP S/4HANA Cloud all versions