Symptom
In your contract, you have maintained Contract Start and Contract End Date. For example, Contract Start Date=2020-11-03 and Contract End Date=2021-11-02.
In the Customer Contract Volume, the Contract Start shows 2020-11-02T16:00:00Z and Contract End shows 2021-11-02T16:00:00Z.
You want to know why the report shows different time format of the Contract Start and Contract End.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Business Analytics work center.
- Go to Design Reports work center view
- Search for the 'Customer Contract Volume' report
- Open and run it
- Go to View > Add Fields to Row
- Add 'Contract Start' and 'Contract End' fields,
- You can see some values (e.g. 2020-11-02T16:00:00Z)
Cause
In the Contract document, it shows the Contract Start Date and Contract End Date (in date format). However, the values are saved in date + time format in the backend. In the Customer Contract Volume report, it uses the date source CRMCCOIB, where the fields are determineding from backend data directly.
Resolution
This is currently the design in the standard data source CRMCCOIB, to show the complete value of contract start and contract end.
Keywords
TIME_POINT_PERIOD-START_TIME_POINT-DATE_TIME; TIME_POINT_PERIOD-END_TIME_POINT-DATE_TIME;CRMCCOIB; Time Format , KBA , AP-CCP-CC-ANA , Analytics , AP-CCP-CC , Customer Contract , Problem