Symptom
Record history displays blank when deleted using the trash icon.
*Image/data in this KBA is from SAP Internal Systems, sample data, or Demo Systems. Any resemblance to real data is purely coincidental.*
Environment
SAP SuccessFactors - Employee Central
Reproducing the Issue
1. Go to user's Profile
2. Click to the Address portlet and click on history button.
3. Select a record to delete, then click on Edit.
4. Click on the trash icon, then click on Save.
Record will be blank
5. Repeat Steps 1 to 3. Click on the Delete button this time
Entire record will be deleted and there will be no blank record
Cause
This is because Home Address is a different entity from other portlets like personal info etc. It has special logic on it that allow discontinuous time slices. Clicking the trash icon will produce discontinuous time slices, so it will cause blank data. The blank is allowed here, so we can confirm this is a standard behavior, since there is no data for the time slice.
Resolution
This behavior is by-design behavior. Clicking the trash icon button will cause blank data on UI and broken time slices on DB.
Using the delete button would be a usual way to remove records.
To request for an enhancement for this, an influence ticket can be raised through this linke: Influence: https://influence.sap.com/sap/ino/
Keywords
Address portlet, Blank Record, Blank History Record , KBA , LOD-SF-EC-PER , Person Data (All Person Data Types) , Product Enhancement