SAP Knowledge Base Article - Public

3035671 - Output Error for Over The Counter Sales Invoices: "Invalid print queue ID BYDCRM_CUSTOMERINVOICE_DEFAULT"

Symptom

Error in Output Document for an Invoice created for an Over the Counter Sales transaction: "Invalid print queue ID BYDCRM_CUSTOMERINVOICE_DEFAULT"

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Customer Invoicing work center.  
  2. Select the Invoice Documents view. 
  3. Open Invoice XYZ (XYZ represents the invoice ID)
  4. Navigate to the Output History tab. 
  5. Check the Error status of the document and click on it. 
  6. It was delivered to print queue ABC, however in the error message says "Invalid print queue ID BYDCRM_CUSTOMERINVOICE_DEFAULT" (ABC represents the print queue).

Cause

When you want to print an over-the-counter sale created from an over-the-counter sale differently in either a Pay Now or Pay Later scenario, then you can do so by using a special print queue. The system will automatically determine the scenario, and will send over-the-counter sales created in the Pay Now scenario to the print queue BYDCRM_CUSTOMERINVOICE_DEFAULT. All other over-the-counter sales will be sent to the print queue defined in the output channel selection for the customer invoices.

Resolution

  • Output configuration for the customer invoice

    1. Select the Application & User Management work center, click on the Input & Output Management view, and click Print Queues.

    2. Define a new print queue, which uses the SAP Collaboration Window.

    3. Change the name of the print queue to BYDCRM_CUSTOMERINVOICE_DEFAULT.

      The system will automatically use this print queue, if it detects that the customer invoice is created in the Pay Now scenario.

  • Output configuration for the order confirmation

    1. Select the Application & User Management work center, click on the Input & Output Management view, and click Print Queues.

    2. Define a new print queue, which uses the SAP Collaboration Window.

    3. Define the name of the print queue.

    4. Select the Application & User Management work center, click on the Input & Output Management view, and click Output Channel Selection.

    5. Set the output channel selection for Invoice Request to channel Printer and assign the created print queue. With these settings, the created print queue will be the default print queue for the output of all order confirmations. Of course, you can also set the print queue name for order confirmations to BYDCRM_CUSTOMERINVOICE_DEFAULT, so that all over-the-counter sales documents are sent to the same print queue.

If you want to generate the document for any affected invoice please cancel the invoice and recreate a new one after the set up of print queue for OTC invoicing for Pay now scenario.

 

See Also

Help Center Document: Over-the-Counter Sales — Printing Documents

Keywords

OTC; Output; Error; Over the counter Sales; BYDCRM_CUSTOMERINVOICE_DEFAULT , KBA , AP-CI-CI , Customer Invoice , Problem

Product

SAP Business ByDesign all versions