SAP Knowledge Base Article - Public

3035752 - Thumbs Up Message Is Blank In Social Interactions Tab Of Ticket

Symptom

When you send a Thumbs Up emoji in Facebook Direct Message and that message is replicated to C4C, the message is seen blank in Social Interactions tab of the Ticket.

Environment

SAP Cloud for Customer 2102

Reproducing the Issue

  1. Send a Thumbs Up message to C4C via Facebook Direct Message
  2. Go to Service work center
  3. Go to Tickets view
  4. Open the Ticket XYZ (Where XYZ indicates the Ticket ID)
  5. Go to Social Interactions tab
  6. The message you sent from Facebook via DM is seen blank

Cause

The Facebook Graph API itself returns the blank message for the Thumbs Up emoji.

Resolution

This behavior only seen for the Thumbs up emoji entered by clicking on the Thumbs Up button in the FB Messenger. Other types of Thumbs Up, For ex: (y) and those entered via the keyboard are shown as expected.

WhatsApp Image 2021-03-16 at 00.10.15.jpeg

This is not a bug and is the expected behavior.

MicrosoftTeams-image (1).png

Here, the first Thumbs Up emoji is entered by clicking on the button highlighed above, where as, the next 2 are entered through the shortcut and keyboard respectively. These 2 are shown as expected. Also, the same behavior is not seen for any other emoji.

Keywords

facebook, like, thumbs up, ticket, blank, empty, interactions , KBA , interactions , ticket , facebook , blank , like , LOD-CRM-SC-SM , Social Media , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer add-ins 2020 ; SAP Cloud for Customer core applications 2102