Symptom
You execute the Period Closure run and notice in the run's application log that results exist for a blocked service agent.
Environment
SAP Business ByDesign
Reproducing the Issue
-
Go to the Application and User Management work center.
-
Go to the Background Jobs view.
-
Search for Period Closure Run.
-
Select the Option All Jobs run in last week from the dropdown list.
-
Select the respective run and press View Application Log.
-
Navigate to the Results tab: One of the results is "Period closure date created for service agent ID XYZ (XYZ represents the service agent ID).
Check the status of the service agent:
-
Go to the Service Agents view in the Business Partner Data or Supplier Base work center.
- Search and select Business Partner XYZ. Result: No business partner found.
-
In the Search field, select All Service Agents.
-
Filter for XYZ.
-
The service agent's status is blocked.
You therefore expect the period closure run to no longer consider the service agent.
Cause
The period closure run still considers blocked employees. Blocking only means that new changes will be blocked. However, the daily period closure run will still run for those service agents. Only obsolete service agents are not considered.
Resolution
For a service agent to no longer be considered by the period closure run, change its status to Obsolete:
- In the Business Partners view of the Business Partner work center find service agent XYZ.
- Press Change Status and select Obsolete.
Keywords
service agent blocked, period closure run , KBA , SRD-HR-TLM , Time and Labour Management , Problem