SAP Knowledge Base Article - Public

3036902 - BYD - No payload data in Web Service Message Monitoring

Symptom

In BYD Webservice Message Monitor, for requests with errors, the payload is always empty.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Workcenter "Application and User Management" -> "Input and Output Management: Web Service Message Monitoring.
  2. Make a selection (e.g. display all messages from the past 24 hours).
  3. Select a message and press "View" -> "Payload". 
  4. A pop-up called "Payload" is displayed, but it's empty and the button "Download" is grayed out.

Cause

In case of synchronous web service calls: Request – Response type of web service calls.This type of service execution provides an immediate response to a query. In this situation, the client (external application) will wait until the server (BYD) sends back the response message.

Successful calls of this type are not recorded by default in web service message monitoring for the primary reason that the source system will get an instant response with the result of the transaction. However, few failed calls will be logged on web service message monitoring which are raised by SOAP Run-time (such as parsing errors), but the payload contents are not stored.

Resolution

The A2X trace internal function in BYD should be active when the request payload is triggered in order to save the payload contents. To activate it, in Web Service Message Monitoring, click "Start Trace" button, then reproduce the issue.

The payload contents should be visible in the monitor after that the request was triggered.

Keywords

BYD A2X TRACE WSM, BYD - No payload data in Web Service Message Monitoring, No error log in Web Service Message Monitoring , KBA , no payload data , no error log , AP-RC-WSM , Web Service Message Monitoring View , AP-RC-CEC-B2B , ByD On-Demand Cloud-Process Integration B2B , How To

Product

SAP Business ByDesign all versions