Symptom
An email or printout output request is created for a service order with the dispatch time set to Immediately. However, the status of the output item remains In Preparation, even though the service order has no errors, is released, and has been saved.
"Image/data in this document is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Go to Manage Order Service app.
- Navigate to the relevant service order.
- Go to Output Control tab.
- Observe that the status of the output item remains In Preparation.
Cause
This is the expected behavior of the Output Control functionality within the Manage Service Orders app.
All unprocessed output items are initially assigned the status In Preparation. This indicates that the output item is ready to be processed but has not yet been sent. While in this status, the output item can still be edited.
Resolution
There are two available options to trigger the output processing:
- In the Manage Service Orders app:
- Navigate to the Output Control tab.
- Select the output item with the status In Preparation.
- Choose Send Output.
- The status will then update to To Be Output, indicating that the item has been marked for processing according to the configured dispatch time.
- Subsequently, the status will automatically update to:
-> Completed, if the output is successfully sent. OR Error, if an issue occurs during processing.
- In the Manage Output Items app,
- Locate the output item with the status In Preparation.
- Select the item and choose Send.
- The status updates and actions behave in the same manner as within the Manage Service Orders app.
See Also
For more information, see Status of Output Items.
Keywords
SAP S/4HANA Cloud Public Edition, Public Cloud, output status, OPD, Immediately, email, printout, dispatch time, output control, service order, SERVICE_ORDER_SUMMARY, To Be Output, Completed, send output, output processing, Manage Output Items, In Preparation , KBA , CRM-S4-SRV-SVO , S4CRM: Service Order , CRM-S4-SRV-SVO-2CL , S4CRM: Service Order (Public Cloud) , How To