Symptom
When logging in the system, you get the following SSO error:
SAML20 SAML20 CX_SAML20: The binding SOAP is not supported during SSO processing. Long text: The binding SOAP is not supported during SSO processing.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Try to logon to your system.
- SSO Error received.
Cause
This means that the SAML response being sent back by the IDP is enveloped into <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" , which is not supported.
Resolution
You need to check the configuration at the IDP to ensure the response is sent in plain way instead of SOAP envelope.
Keywords
KBA , LOD-CRM-SEC , Security Topics , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions