SAP Knowledge Base Article - Public

3037572 - How to switch from one custom IdP to another custom IdP in SAP Analytics Cloud (SAC)

Symptom

The following behavior occurs in SAP Analytics Cloud (SAC) when trying to switch from one custom IdP to another:

  • Uh oh. Something went amiss

Environment

  • SAP Analytics Cloud (Enterprise)
  • Custom Identity Provider (IdP)

Reproducing the Issue

1. Logon SAC.
2. Go to System > Administration > Security.
3. Start changing SAML SSO.
4. Verify Account and open URL in Chrome incognito mode.
5. Logon SAC by using verify user.
6. Error occurs.

Cause

SAP Analytics Cloud does not support switching from custom IdP to another custom IdP.

Resolution

  1. Revert from Custom IdP "A" to the default IdP.
  2. Configure Custom IdP "B".

For making these changes, please use the IdP Admin tool as per the following document: 2908073 - How to use the IdP Admin Tool to make changes to IdP Configuration in SAP Analytics Cloud or Datasphere when no access is available to the tenant

See Also

Your feedback is important to help us improve our knowledge base.

Keywords

SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics,Error, Issue, System, Data, User, Unable, Access, Connection, Sac, Connector, Live, Acquisition, Up, Set, setup, Model, BW, Connect, Story, Tenant, Import, Failed, Using, Working, SAML, SSO, sapanalyticscloud, sap analytical cloud, sap analytical cloud, SAC, sap analyst cloud, connected, failure, stopped , KBA , LOD-ANA-AUT , SAC Authentication / Login , Problem

Product

SAP Analytics Cloud 1.0