SAP Knowledge Base Article - Public

3037882 - Error Occurs When Entering a Product in a New Manual Invoice for an Account Located in Canada

Symptom

The following error occurs in a New Manual Invoice when entering a product:

Tax region for country Canada in item 10 is missing. You have to set the tax jurisdiction code manually on the Taxes tab.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Customer Invoicing work center.
  2. Select the option New Manual Invoice in the Common Tasks.
  3. Enter Account XYZ (XYZ represents the ID of the Account).
  4. Enter all other data such as Employee Responsible, Sales Unit etc.
  5. In the Items section click on Add Row and enter a Product.
  6. Following error occurs: Tax region for country Canada in item 10 is missing. You have to set the tax jurisdiction code manually on the Taxes tab.

Cause

The error occurs because the Region (Province) is not maintained in Address of the Account Master Data of the Ship-To Party.

Hence in the Items tab and the Taxes sub tab the Tax Region cannot be determined.

Resolution

You can either maintain the Tax Region manually in the Items tab and Taxes sub tab of the Invoice Request of you can maintain the Region (Province) in the Address of the Account Master Data of the Ship-To Party.

Once you maintain the Provide in the master data the error will not occur when creating a New Manual Invoice Request.

Keywords

Tax Region; Canada; Province; Region; , KBA , SRD-CRM-INV , Customer Invoicing , Problem

Product

SAP Business ByDesign 2102