Symptom
Using the Upsert operation, you want to add an owner to a ticket with Closed status, but this is not possible and the following error is thrown: "Field is Read-Only".
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Data Workbench work center
- Select Import view
- Select Upsert
- Search and select the object: Service Request
- Click Next
- Browse for the file
- Click Upload
- Click Next
- Click Import
- Go to the Monitor view to check the error file
- Find error: Field is Read-Only
Cause
This error occurs due to the fact that you are using Upsert operation to add an owner to a closed ticket.
Resolution
Adding an owner to service requests in closed status is only possible by selecting import operation as Insert and Initial Load as “ON”.
Keywords
KBA , LOD-CRM-INT-DWB , Data Workbench , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions