SAP Knowledge Base Article - Public

3038371 - Field is Read-Only Error When Adding Owner to Service Requests in Closed Status Using Data Workbench

Symptom

Using the Upsert operation, you want to add an owner to a ticket with Closed status, but this is not possible and the following error is thrown: "Field is Read-Only".

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Data Workbench work center
  2. Select Import view
  3. Select Upsert
  4. Search and select the object: Service Request
  5. Click Next
  6. Browse for the file
  7. Click Upload
  8. Click Next
  9. Click Import
  10. Go to the Monitor view to check the error file
  11. Find error: Field is Read-Only

Cause

This error occurs due to the fact that you are using Upsert operation to add an owner to a closed ticket.

Resolution

Adding an owner to service requests in closed status is only possible by selecting import operation as Insert and Initial Load as “ON”.

Keywords

KBA , LOD-CRM-INT-DWB , Data Workbench , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions