SAP Knowledge Base Article - Public

3038671 - Time Type Missing for Employee

Symptom

When recording a time for an employee, no time types are available in the dropdown list.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Time Administration work center.
  2. Enter the Employees view.
  3. Search for the required employee.
  4. Click on the Edit button.
  5. Go to the Employee Times tab.
  6. Add a new row.
  7. Open the dropdown for Time Type.

Here, no value is displayed for selection.

Cause

The time types available for a certain employee are determined by the country for which the employee was hired.

This means that in the Regular Tasks view of the Personnel Administration work center, if country Germany is selected when the Hire Employee task is entered (as an example), the employee will be hired for Germany and only Germany time types will be available for usage in the time recording.

It is possible to check the country for which an employee was hired by following the below steps:

  1. Go to the Personnel Administration work center.
  2. Enter the Employees view.
  3. Click on the user avatar icon on the top-right of the screen.
  4. Click on Enter Personalization Mode.
  5. On the panel that opens on the right side of the screen, click on the Employees section.
  6. Select the checkbox for field "Country/Region".

In case this needs to be changed, it is required to either:

  1. Hire a new employee in the correct country
  2. Terminate and rehire the existing employee in the correct country.

Resolution

In order to check more details on how to hire or re-hire the employee, please refer to the Employee Life Cycle documentation available on the Help Center, which is also linked in the See Also section of this KBA.

See Also

 Help Center - Employee Life Cycle

Keywords

Employee Times, Time Type, Country, Hire, Nationality , KBA , SRD-HR-TLM , Time and Labour Management , How To

Product

SAP Business ByDesign all versions

Attachments

Hire Country.PNG