Symptom
When user record a time manually using the Employee Times or when a Time Administrator adds Employee Times for a user, no Time Type is avaiable to select.
Reproducing the Issue
- Time Administration workcenter
- Employees
- Search and Edit required Employee
- Go to Employee Times tab
- Add a new row
- Open the dropdown for Time Type
Here you can see that no value is available
Cause
You have entered ABC for the country while migrating Personnel Administration Data. This means while he is assigned to another XYZ country company, he was hired in ABC and therefore the system expects ABC Time Types. And as ABC is not scoped as a country, the system will not find any time types.
You need to either hire a new employee in the correct country or terminate and rehire this employee to the correct country. You might want to change the hire date to and earlier date before terminating though so that you can set the new hire date to the one you planned to set it ona nd try in Test System first.
Resolution
Now, you need to either hire a new employee in the correct country or terminate and rehire this employee to the correct country. You might want to change the hire date to and earlier date before terminating though so that you can set the new hire date to the one you planned to set it ona nd try in Test System first.
You can check the country of hire in UI directly :
- Go To Personnel Administration workcenter
- Employees view
- Go to Personalisation Mode and expand the Employees UI Element
- A field ‘Country/Region’ is available to select.
This will show the country of Hire for the employee. It is not necessary to save the personalisation as the country will appear on the UI immediately without saving the personalisation.
Keywords
Employee Times, Time Type, Country, Hire, Nationality , KBA , SRD-HR-TLM , Time and Labour Management , Problem
Product
Attachments
Hire Country.PNG |