Symptom
You are updating accounts via the web service request II_MANAGE_CUSTOMER_IN and you notice that the request deletes the main address data such as:
Country/Region, Street/House Number, Postcode/City, State, Phone, Fax, E-Mail and Language.
Environment
SAP Business ByDesign
Reproducing the Issue
Sample Payload:
<env:Envelope xmlns:env="http://www.w3.org/2003/05/soap-envelope" xmlns:ns1="http://sap.com/xi/AP/CustomerExtension/BYD/A2DZB" xmlns:ns2="http://sap.com/xi/SAPGlobal20/Global">
<env:Body>
<ns2:CustomerBundleMaintainRequest_sync_V1>
<Customer actionCode="02" AddressInformationListCompleteTransmissionIndicator="true">
<InternalID>XYZ</InternalID>
<ns1:ABC>sample@sampleemail.com</ABC>
</Customer>
</ns2:CustomerBundleMaintainRequest_sync_V1>
</env:Body>
</env:Envelope>
XYZ: Account ID
ABC: Field or Data to be updated
Cause
You set the AddressInformationListCompleteTransmissionIndicator to “True”
This means, that the system expects all AddressInformation data to be sent.
In the above sample payload no AddressInformation data is sent, and therefore the AddressInformation data + any sub data (like Postal Address, E-Mail etc.) is deleted.
Resolution
You need to set the Transmission Indicator to “False” to allow the system to treat the request as delta load, hence avoid the deletion of any sub data.
Keywords
removes, deletion, missing, not available , KBA , AP-BP-BP , BusinessByDesign: Business Partner , Problem
SAP Knowledge Base Article - Public