SAP Knowledge Base Article - Public

3039903 - Mandatory Property is not working on Popover Modal screen

Symptom

You wanted to set the mandatory property on a popover field, but you see that it is not working as expected

Environment

SAP Cloud for Customer

Reproducing the Issue

In our scenario, we will consider the field Reason for Status from opportunity

  1. Enter Adaptation Mode
  2. Go to Sales workcenter
  3. Go to Opportunities view
  4. Select show all and find for LMN (LMN represents the name of the opportunity)
  5. Select the option Set as Lost from Actions

In this stage, system will show the popover window (modal window), with the field Reason for status and setting mandatory property here is not working.

Cause

Considering the design framework it is advised not to mark field as mandatory if it's on modal window. From user flexibility side certain KUT operations will be removed in phases.

Resolution

This feature is not supported in the current release of SAP Cloud for Customer and you can check for other feasible options like restricting via rule valdiation/ Partner Development Infrastructure.

1.  If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder

2.  If you are a customer:

  1. Contact your Account Executive
  2. Check the link https://www.sap.com/uk/services/advisory-development.html

C4C: An alternative option may be to check the “SAP Cloud for Customer” Customer Influence to submit an idea https://influence.sap.com/sap/ino/#/campaign/1868

Keywords

Mandatory, KUT Property, Modal Dialog, Popover, Not working , KBA , AP-RC-UIF-FLX-FRW , UI Adaptation Framework , AP-RC-UIF , C4C UI Framework , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions