Symptom
You are trying to create a workflow rule on Appointment / Account / Individual Customer business object and wanted to send a survey, but you receive the below error
Referenced object BUSINESS_ACTIVITY is not supported / Referenced object Customer is not supported
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Administrator Workcenter
- Go to workflow Rules view
- Create a New workflow rule as below
- In the basic data step, enter description and select Business Object: Appointment
- Maintain the desired conditions
- In the step, define actions, select Rule Type: E-Mail and maintain the subject, Template File, recipients and relevant survey placeholder
- Review the workflow and Select Activate
You will see the error Referenced object BUSINESS_ACTIVITY is not supported
Cause
There are certain consistency checks done for survey related placeholders during design time from workflow side a failure of it will result in error message.
Resolution
You can use surveys via workflows only for business activities of type Phone call and visit. You cannot use surveys for appointments or customers, etc.
This is the standard behavior of the system.
If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
An alternative option may be to check the corresponding SAP Customer Influence Site to submit an idea:
Keywords
Survey, appointment, Phone call, Visit, error, workflow,Referenced, object, BUSINESS_ACTIVITY, not supported , KBA , LOD-CRM-WKF , Workflow , LOD-LE-SUR-EXE , Survey execution = runtime , Problem