SAP Knowledge Base Article - Public

3040815 - Not able to attach files from Local Drive in C4C Mobile App

Symptom

 Not able to attach files from Local Drive in C4C Mobile App

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Log on to the C4C Mobile App.
  2. Go to WoC Service > Tickets.
  3. Open any Ticket.
  4. Go to the 'Attachment' tab.
  5. Click the button 'Upload file'.
  6. Observe that there is only the option to take a 'New Photo'.
  7. User is expecting the option to also add an existing file from the device.

Cause

The option 'Disable Image Upload from Device Folder/Gallery' must be enabled in customer's tenant.

Resolution

Please navigate through the following steps to uncheck this option;

  1. Go to Administration > General Settings > Mobile Settings.
  2. Uncheck the option 'Disable Image Upload from Device Folder/Gallery' if you wish to add new photos and existing files from your device.

     

     Image/data in this KBA is from SAP internal systems. Any resemblance to real data is purely coincidental.

Keywords

attach file, image upload, mobile app, mobile settings , KBA , AP-RC-MOB-IPD , SAP Hybris Cloud for Customer Extended App on iOS , AP-RC-MOB-UIF , Responsive UI , Problem

Product

SAP Cloud for Customer core applications all versions