Symptom
Not able to attach files from Local Drive in C4C Mobile App
Environment
SAP Cloud for Customer
Reproducing the Issue
- Log on to the C4C Mobile App.
- Go to WoC Service > Tickets.
- Open any Ticket.
- Go to the 'Attachment' tab.
- Click the button 'Upload file'.
- Observe that there is only the option to take a 'New Photo'.
- User is expecting the option to also add an existing file from the device.
Cause
The option 'Disable Image Upload from Device Folder/Gallery' must be enabled in customer's tenant.
Resolution
Please navigate through the following steps to uncheck this option;
- Go to Administration > General Settings > Mobile Settings.
- Uncheck the option 'Disable Image Upload from Device Folder/Gallery' if you wish to add new photos and existing files from your device.
Image/data in this KBA is from SAP internal systems. Any resemblance to real data is purely coincidental.
Keywords
attach file, image upload, mobile app, mobile settings , KBA , AP-RC-MOB-IPD , SAP Hybris Cloud for Customer Extended App on iOS , AP-RC-MOB-UIF , Responsive UI , Problem
Product
SAP Cloud for Customer core applications all versions