SAP Knowledge Base Article - Public

3040878 - Enabling "Enable Mobile Access" field for Skillsoft Percipio Courses - [LMS]

Symptom

*Note All self-implemented changes performed without a certified partner engaged and handling this implementation , any risks involved with connectors falls directly on the implementer. Should irreversible/incorrect data be injected into the database via a connector, you may need to engage professional services to roll back the server*

Courses that are imported from Percipio Skillsoft via Item Connector are not Mobile Enabled

Environment

SAP SuccessFactors Learning Management System

Skillsoft Percipio

Reproducing the Issue

Skillosft pushes item and content object related information via item_data connector file and even though ENABLE_MOBILE_ACCESS is passed properly in the Item Connector Feed file that they place in the SFTP, that is not getting reflected in the LMS system.

Cause

The issue here is because of the missing connector configuration to process those missing fields.

Resolution

Login as a LMS Admin->System Administration->Configuration->System Configuration->CONNECTOR->Click on Edit option next to it(Pen and paper icon])->add the following two line anywhere in a new line->Apply changes

item.field.mapping.data.ENABLE_MOBILE_ACCESS=ENABLE_MOBILE_ACCESS

item.field.mapping.data.MOBILE_PRIMARY_PARAM=MOBILE_PRIMARY_PARAM

NOTE : Doing the above mentioned would enable "Mobile Access" flag only for the future contents that Percipio pushes from their side into the LMS system as Skillsoft informed us that they push only Delta files and not all.

What does that mean for previously imported courses from Percipio and how to fix them:

1) you could either go to the previously imported contents and enable this field directly. Login as a LMS Admin->Content->Content Objects->Search and open the content object you are having this issue->Edit(Pen and paper icon next to the Object ID)->Launch Method->make sure to check "Enable Mobile Access"->Apply Changes (After this is performed, you do not have to reassign the related item to anyone and this feature would appear with immediate effect to users), --or--

2) For updating mobile option in bulk for the existing content Objects in the LMS system (This could be done by you or your partner that would fix the issue for existing content objects)

- Please check the attached sample content object connector feed file that can be consumed by the Item Connector in the system.
 
The required fields are :

************************************************************************
APP_ID – Content Object ID
TITLE – Title of the Content Object
NOTACTIVE – set this to N for all the content objects (setting this to N means the content object is active)
ENABLE_MOBILE_ACCESS – set this to Y

************************************************************************
 
You can ignore all the other fields (in the content_module_data.txt) and leaving them would still let the Content Objects retain the previous values.
 
Try this in the Non-Production LMS instance (like Stage or Sandbox) with one content object and then with multiple and then implement the same in the PROD with the content objects you need to fix. If there are any concerns or queries, feel free to reach out to LMS support team via the LOD-SF-LMS-CON ticket component.

Keywords

Percipio mobile enabled, skillsoft mobile, app inaccessible, skillsoft lms, skillsoft successfactors, ENABLE_MOBILE_ACCESS , KBA , LOD-SF-LMS-MOB , Mobile Application Issues Only , Problem

Product

SAP SuccessFactors Learning all versions

Attachments

content_module_data.txt