SAP Knowledge Base Article - Public

3040891 - C4C - Error "No Communication Arrangement maintained" in CRM Customer Fact

Symptom

In the C4C Account screen, when clicking on "CRM Customer Fact sheet" action, the following error message is raised: 'No Communication Arrangement maintained'.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work center.
  2. Go to the Accounts view.
  3. Open the an account.
  4. Click on Actions menu-> CRM Customer Fact sheet.

Cause

There is no ID Mapping maintained for the C4C local account under "ERP Accounts".

Resolution

The ID Mapping should be automatically created during confirmation message from CRM. Please check if the CRM confirmation IDOC CRMXIF_PARTNER_SAVE_M03 was correctly generated and sent to C4C. If not, then the ID mapping can be updated manually in C4C.

Keywords

C4C CRM FACTSHEET , KBA , LOD-CRM-INT-CRM , Integration of C4C with CRM , How To

Product

SAP Cloud for Customer core applications 2102