SAP Knowledge Base Article - Public

3041386 - Unexpected File Name When Downloaded from Attachments Facet

Symptom

When you download an attachment from Ticket's Attachments facet the file name is different from the file name when you download it from Library Workcenter.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Service Workcenter
  2. Go to Tickets view.
  3. Open a Ticket that has attachments.
  4. Go to Attachments facet.
  5. Download the file.
  6. You can see that the file name is different from the name that you expected.
  7. Now, go to Library Workcenter.
  8. Go to Attachments view.
  9. Download the same attachment. 
  10. You can see that the file name is correct and as expected.  

Cause

There is a difference in implementation (of the download option) when the file is downloaded from the Attachments facet compared to when it is downloaded from Library Workcenter.

The value which is seen when the file is downloaded from the Attachment facet corresponds to the column "File name" of the attachment. When the file is downloaded from Library, however, the file name is taken from column "Title".

Resolution

This is the expected system behaviour.

    1. If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder.

    2. If you are a customer:            
      1. Contact your Account Executive.
      2. Check the link for SAP Advisory Services.

    Keywords

    Attachment's name ; Attachments facet ; Library workcenter ; Unexpected name ; Wrong name , KBA , LOD-CRM-SRP-CSI , Integration of service ticket with Core systems , How To

    Product

    SAP Cloud for Customer add-ins all versions