Symptom
When launching an Item from 'To Do' tile, the following error occurs:
''This item does not have any online objects available at this moment"
Environment
SAP SF Learning
Reproducing the Issue
- Login to SuccessFactors Learning as a User.
- Launch affected Item/ Online Course from 'To Do' tile.
Cause
Cache issue with the content itself or browser cache.
Resolution
- Firstly, try to clear browser cache and test again to see if it works.
- If this doesn't work then re-import the online content. Re-import is referring to create a new online content (by importing the same online content but this time as a new content object).
- Then Assign/ attach to an item.
- Then assign Item to a user.
- Test again to see if user is able to launch the content this time.
- If you still have an issue then try to assign an Item again to the affected users using Content Reassignment Wizard as per the following KBA:
2328118 - Using the Content Reassignment wizard to reassign an item to user(s) - Select only the users who are facing the issue and un-select others. Above KBA shows how to do that.
-
If you use the Content Reassignment wizard on all the users. Using the Content Reassignment wizard will only reassign the content and never the item itself. It will not affect users who have completed or haven't started the Item. Only the users who are currently in progress will have to start again.
Note: Use only Content Reassignment Wizard and Do Not assign via Assignment Profile (AP) in this case.
See Also
2184107 - Unassigning multiple items from multiple users in LMS
Keywords
warning, class, online offering, schedule offerings, content, lms, item , KBA , LOD-SF-LMS-ITE , Items , Problem
Product
SAP SuccessFactors HCM Core all versions