SAP Knowledge Base Article - Public

3041900 - Error 'Address Incomplete; Enter Country' After C4C Move-In or Contract Account Creation

Symptom

After creating a new contract account or performing the move-in function in C4C, the following error is raised: ''Address Incomplete; Enter Country'' Message no. AM216.

Environment

SAP Cloud For Customer

Reproducing the Issue

  1. Go to the Customers work center.
  2. Go to the Accounts view.
  3. Open account DEF(DEF is the account name).
  4. Click on the Move-In.
  5. Enter Premise and Move-In date and choose the Next button.
  6. In Meter reading section- click on Estimate and Next.
  7. Click on Move-in Using MDT

When the Move-In is sent to ISU, there is an error ''Address Incomplete; Enter Country''.

Cause

Country field is not maintained in the MDT Template in the ISU system.

Resolution

In the ISU system, maintain the country in the used MDT template by entering the transaction code EPRODCUST.

Keywords

Utilities move address country, MDT, AM216. , KBA , LOD-CRM-IND-UTL , Utilities , How To

Product

SAP Cloud for Customer core applications all versions