Symptom
- Sometimes user is unable to receive the emailed report if the report size is too big, what is the size threshold for the attachment for an emailed report in LMS?
- Is it possible to increase the threshold?
Environment
SAP Successfactors Learning
Reproducing the Issue
- Go to LMS Administration page > Reports
- Run a report without many criteria set to make the report size large
- Check the 'Email Report' checkbox in Schedule Job screen
- User didn't receive the emailed report.
Cause
The attachment size exceeded 18MB.
Resolution
After b2005 release, an internal configuration was added to tenant level. The threshold for attachment only in emailed report job is now set to 18MB.
The threshold is to ensure health load balance on report node server, it cannot be increased.
Customer can enable the property 'enableZippedReportNotification ' in REPORT_SYSTEM configuration file to decrease the attachment size.
LMS > System Administration > Configurations >System Configuration > REPORT_SYSTEM:
#This configuration will enable emailed report outputs to be zipped to reduce large report size during transfer. By default this is set to true to maximize the ability to send reports over email under the email size thresholds.
#When set to true report outputs will be delivered as zipped files. Setting this to false will email the reports in the direct uncompressed output format.
enableZippedReportNotification=true
Keywords
emailed report size limitation , KBA , LOD-SF-LMS-NOT , Notifications , Problem