Symptom
You receive the one of following diagnostic messages from the system via a health check incident.
- "System cannot assign BTM items of type XYZ"
- "Assignment of type XYZ BTM items not possible"
(Where XYZ represents the task ID)
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Application and User Management work center.
- Access the Incidents work center view.
- Set selection to New Incidents.
- Here, you can see incident(s) with subject "System cannot assign BTM items of type XYZ" or "Assignment of type XYZ BTM items not possible"
Cause
These health check incidents are raised in case there are tasks which are in unassigned status, since the person responsible for the task cannot be determined.
If the system cannot determine an appropriate user to whom the items can be distributed, the items will not appear in the worklist of any users, which can result in delays in the business processes affected.
Resolution
Generally, you can follow the steps below as resolution for these health check incidents.
- Go to the Application and User Management work center.
- Access the Business Task Management work center view.
- Set selection to Unassigned Items.
- Click Go.
- To determine why an item has not been assigned to a user, select it and open the most recent application log.
- Solve the issue by, for example, adjusting the work distribution settings or work center view assignments to ensure that the potential user responsible has the necessary work center assignment.
- You can adjust the work distribution settings under Application and User Management > Task Distribution > Employee Work Distribution.
- You can also adjust the work center view assignments under Application and User Management > Business Users or Application and User Management > Support and Technical Users.
- After you have made the relevant changes, return to the Business Task Management view, select the relevant item, and choose Determine Assignment.
- The system assigns the item according to your changes and removes it from the list.
- You can also manually assign the item to the employee responsible by selecting it in the Business Task Management view and clicking Actions > Assign Item. For any task, you can assign the responsible user to the task or you can delete/cancel the task.
Note: If more than one key user has access to the Application and User Management work center, the full list of Tasks for which no user is responsible might be distributed between these key users.
If you are still unable to solve the issue, report an incident to SAP.
In the incident, include the type of Business Task Management Item specified in the message text of the Health Check incident you received, as well as any further related information. Do not forward the incident you received to SAP, since it is closed automatically if you assign the item manually.
To avoid delays in the business processes affected while the incident you have reported is being solved, you can manually assign the item(s) to the employee(s) responsible by selecting the item(s) and click Action, then Assign Item.
Keywords
System Cannot Assign BTM Items of Type, Assignment of Type XYZ BTM Items Not Possible, Health Check, Business Task Management , KBA , SRD-CC-BTM , Business Task Management , Problem