SAP Knowledge Base Article - Public

3043162 - Extension Field Value Disappears While You Click on the Check Button in the Invoice Request

Symptom

You have created an extension field in the Service Order screen, after entering a value in the extension field, when you click on the Check button in the Invoice Request Screen system overrides the value of the extension field and it becomes blank.

Environment

SAP Business ByDesign.

Reproducing the Issue

  1. Go to the Customer Invoicing work center.
  2. Select the Invoice Requests view.
  3. Search for the Outbound Delivery Invoice Request ABC (ABC represents the ID of the Outbound Delivery).
  4. Click the Edit button.
  5. Navigate to Items tab.
  6. Click on the Check button.

 You could see that the extension field has become blank.

Cause

The check button in the Customer Invoice Request QAF/OIF is a check and detemine action.

This means that it will redetermine the values, when the button was clicked. This means that it will redetermine the product information and as part of this it is redetermine the extension fields.

This will occur only on the item level as this is where the determination is occuring.

Resolution

This is the system expected behavior.

Keywords

Extension Fields; Customer Invoice; Invoice Request; Check , KBA , AP-CI-CIR , Customer Invoice Request , How To

Product

SAP Business ByDesign all versions